Blog Download Documentation Forum Tasks Home
Blog Download Documentation Forum Tasks Home

Vanilla 1.1.3 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorsteve
    • CommentTimeFeb 16th 2008
    I've setup radria using the beta 0.8.4. I cannot get the image upload to work. After browsing the local drive, selecting a file and then clicking Add, the program appears to work, however, no image is uploaded. No error messages appear in radria_error.log. I thought it might be a php error of some type, however, I *can* upload images using the Images with Link Add-on perfectly. Once the image is uploaded, it appears in the library. Then I can add it from there.

    FTP sync doesn't seem to work either. Watching the apache logs, something seems to happen when I click upload, however, the resulting page is blank. As with the image problem, no image appears in radria_error.log.

    I've installed this on a fresh installation of CentOS 5.1. As CentOS uses the bz2 php module and doesn't include the zip module, I've installed zip and unzip to the system. Any ideas with what might be going on here?
    • CommentAuthorphilippe
    • CommentTimeFeb 18th 2008
    For the images, try to upload images less than 2MB

    For the FTP sync, check that you have the FTP extension installed.
    Then in the SiteManager/config.php
    Change this line:
    define("SITEMANAGER_LOG_RUN_SYNC", false);
    to True
    And in:
    to True

    Setup the FTP, Run the sync / publish and then look at the radria_run.log
    It will give you details information on the FTP sync.
    • CommentAuthorsteve
    • CommentTimeFeb 18th 2008
    The image I was trying to upload was 21kB.

    FTP extension? I've got the ftp program installed which was verified by the installer. I don't see any ftp package in the Site Manager. I'm not sure what you are referring to.

    I activated the SITEMANAGER_LOG_RUN_SYNC and I now see:

    Checking the files that need to be uploaded (files: Array) or deleted (skip: 543
    file to upload: 317
    file to delete: 0
    End Event webide.SynchronisationCheckFiles

    I just checked your intro video again and I see that I'm supposed to see a list of files to be transferred with a checkbox by each. I'm still getting a blank page.

    Also, on the FTP Setup page in Site Manager, I've left the bottom three options unchecked. I see in your video it looks like you have the second one checked. I'm not doing a database on the target site, so I'm guessing I don't need those options. Am I correct to assume that Site Manager will actually sync the local database with a remote one if it uses a database say for dynamic content?
    • CommentAuthorphilippe
    • CommentTimeFeb 19th 2008
    Yes, it can sync the database, you can sync the data or the schema structure.

    I often never use the sync data but the sync for the schema is very useful.

    Yes you should see a list of files that will be uploaded or deleted.

    If the page is blank its possible that there is an Error and it doesn't display it.
    Do you have PHP errors in the logs ?
    Can you turn on Display errors for the PHP errors ?
    • CommentAuthorsteve
    • CommentTimeFeb 19th 2008
    Here's what I get when I display PHP errors on the page:

    The requested URL /SiteManager/<br /><b>Notice</b>: Use of undefined constant MYDB_EVENT_SECURE - assumed 'MYDB_EVENT_SECURE' in <b>/var/www/html/RadriaCore/class/Event.class.php</b> on line <b>150</b><br />eventcontroler.php was not found on this server.

    And, in the apache logs:

    [Tue Feb 19 10:39:38 2008] [error] [client] PHP Notice: Undefined
    index: syncdata in /var/www/html/RadriaCore/class/Report.class.php on line 268
    , referer: http://pb.4test.net/SiteManager/editftpsync.php?x=1&project_name=bow
    [Tue Feb 19 10:39:38 2008] [error] [client] PHP Notice: Undefined
    variable: defaultvar in /var/www/html/RadriaCore/class/Registry.class.php on li
    ne 190, referer: http://pb.4test.net/SiteManager/editftpsync.php?x=1&project_na
    [Tue Feb 19 10:39:38 2008] [error] [client] PHP Notice: Undefined
    variable: fval in /var/www/html/RadriaCore/class/Registry.class.php on line 756
    , referer: http://pb.4test.net/SiteManager/editftpsync.php?x=1&project_name=bow
    [Tue Feb 19 10:39:46 2008] [error] [client] File does not exist: /
    var/www/html/SiteManager/<br , referer: http://pb.4test.net/SiteManager/editftp
    • CommentAuthorsteve
    • CommentTimeFeb 22nd 2008
    I re-worked the error logging again and found a more specific error:

    PHP Parse error: syntax error, unexpected ';', expecting ',' or ')' in /var/www/html/SiteManager/checksync.php on line 86

    I don't see anything wrong with this line. Any thoughts?
    • CommentAuthorsteve
    • CommentTimeFeb 22nd 2008
    Well, on closer examination, there is an error:

    on lines 86 and 87, there is a missing ")" before the semi-colon on each line. Adding it removes the error and now I get a list of files.

    I'm a little surprised no one else ran into this. Perhaps I should be using SVN?
    • CommentAuthorsteve
    • CommentTimeFeb 22nd 2008
    Still no luck on the other error with the image upload. One problem logged is a division by zero error:

    PHP Warning: Division by zero in /var/www/html/bowling/pb_addlayer.sys.php on line 1277

    I'm not sure why that's happening, however, it doesn't seem to be a show stopper.

    The other problem: File does not exist: /var/www/html/bowling/includes/style.sys.css, referer: http://pb.4test.net/bowli

    I just copied the file includes/style.css to includes/style.sys.css to get rid of the error. Still no luck with the overall problem of uploading images. After clicking "Add", pagebuilder just returns to the "Edit Page" screen. Checking the "Layers" screen shows that the layer is added, however, without the image.

    Am I the only one with this problem?
    • CommentAuthorphilippe
    • CommentTimeFeb 25th 2008
    I had that problem, its was some max file size values set to low in the pb_addlayer.sys.php file.

    But it got fixed in pagebuilder 3.8 I suppose because I don't have it anymore.
    • CommentAuthorsteve
    • CommentTimeFeb 26th 2008
    That is not the problem as I see <input type="hidden" name="MAX_FILE_SIZE" value="200000000">.

    How does this apparently work for everyone except me??? I did find the other syntax error I mentioned above. Should I be using version in svn?
    • CommentAuthorphilippe
    • CommentTimeFeb 26th 2008
    Yes, try the version on SVN its the one I use and works fine for me (Ubuntu)

    We will release today or tomorrow the final 0.8.4, its close to the current svn
    • CommentAuthorsteve
    • CommentTimeMar 4th 2008
    I just deleted everything and performed a clean install from svn. The image upload still does not work! My install passed your requirements test and I followed the wiki install and getting started guide exactly. Unless there is some magical php.ini setting that I missed (like must have register_globals set to on or something like that, there is without a doubt a problem with this version (rev 60).

    What further convinces me that this is an error somewhere in the code is that I *can* upload images to use as a link. If php were incorrectly configured, wouldn't that be impossible?
    • CommentAuthorphilippe
    • CommentTimeMar 5th 2008
    this is correct its a bug.

    The problem is I can't reproduce it, as it work on my rev 60 install. Its probably a specific php/apache version that has this bug/problem.
    • CommentAuthorsteve
    • CommentTimeMar 5th 2008
    I've got this setup on a VPS and would be happy to give you full access to it if you are interested. It's on CentOS 5.1.
    • CommentAuthorphilippe
    • CommentTimeMar 6th 2008
    sure, send your contact information at support@sqlfusion.com
    I get the same ftp error on windows xp and using the uniform wamp package.
    Parse error: syntax error, unexpected ';', expecting ',' or ')' in W:\www\radria\SiteManager\checksync.php on line 86

    I've not had a chance to play with it much on windows, but I plan to look more into specific windows problems since I'll be using it more.

    Thanks for Radria 8.4. I'm still playing with as it's one of the best things that I find for free on the Internet
    • CommentAuthordfordham
    • CommentTimeDec 17th 2008

    To fix the Parse error: syntax error, unexpected ';', expecting ',' or ')' in W:\www\radria\SiteManager\checksync.php on line 86

    ...edit lines 86 & 87 in ..SiteManager/checksync.php from...

    Line 86 unset($_SESSION["filetoupload"];
    Line 87 unset($_SESSION["filetodelete"];


    Line 86 unset($_SESSION["filetoupload"]);
    Line 87 unset($_SESSION["filetodelete"]);

    Notice the ) in both lines of code after the ] and before the ending ;
    • CommentAuthorphilippe
    • CommentTimeDec 23rd 2008
    or try the svn version from sourceforge:
    • CommentAuthorsteve
    • CommentTimeSep 19th 2010
    Even using the latest svn version the image upload still doesn't work. Are there plans to fix this? Why would the image with link upload work, but the plain image upload not work? Is it coded differently? I'm using CentOS 5.5 with EPEL PHP 5.2.10 including all modules required per radria installation notes.
    • CommentAuthorsteve
    • CommentTimeSep 22nd 2010
    OK, I think I found the problem here. I'm guessing this has to do with the more modern PHP in the new distros as you use $HTTP_POST_FILES instead of the newer $_FILES. A global change of this seems to make image uploading work properly.
    • CommentAuthorphilippe
    • CommentTimeSep 23rd 2010
    yes those where left from the "old days" didn't realize until they got removed of PHP.

    we are working toward an upgrade for php5.3.

    Feel free to send us patches to the current radria